0

Ever since migrating the site, I have been unable to open the Flag edit form from the Flag module UI, as well as the "Patterns" page in the Pathauto interface. I checked the error log in my home folder on the server and these are the errors I see:

    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #0 /home/mysite/public_html/includes/database/database.inc(2168): PDOStatement->execute(Array), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #1 /home/mysite/public_html/includes/database/database.inc(680): DatabaseStatementBase->execute(Array, Array), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #2 /home/mysite/public_html/includes/database/database.inc(2347): DatabaseConnection->query('SELECT expire, ...', Array, Array), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #3 /home/mysite/public_html/includes/lock.inc(167): db_query('SELECT expire, ...', Array), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #4 /home/mysite/public_html/includes/lock.inc(146): lock_may_be_available('theme_registry:...'), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #5 /home/mysite/public_html/includes/theme.inc(449): lock_acquire('theme_registry:...'), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #6 /home/mysite/public_html/includes/bootstrap.inc(446): ThemeRegistry->set(Array), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #7 [internal function]: DrupalCacheArray->__destruct(), referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: #8 {main}, referer: http://xxx.xxx.xxx.xxx/
    [Mon Feb 24 16:57:56 2014] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr:   thrown in /home/mysite/public_html/includes/database/database.inc on line 2168, referer: http://xxx.xxx.xxx.xxx/

PHP version - 5.3.10 Memory allocated - 256M

  • 1
    Are you positive it's php 5.0? If so that's likely to be the problem as D7 requires >5.2.5 – Clive Feb 24 '14 at 16:14
  • Virtualmin says "In domain [domainname] Your system only has PHP version 5 installed, so selecting a different version for each directory is not possible." – alouette Feb 24 '14 at 16:17
  • okay, now I figure that doesn't mean that the version is 5.0 – alouette Feb 24 '14 at 16:21
  • You can get your current version from the command line with php -i | grep "PHP Version", or even through Drupal at /admin/reports/status – Clive Feb 24 '14 at 16:28
  • Thanks. PHP version 5.3.10-1ubuntu3.9. I will edit my original post. – alouette Feb 24 '14 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.