0

I did an update of several modules (core included, from 7.xx to 7.26), a couple of weeks ago, and until now I had not tried to access content types.

Today I did, but while I can see the 'manage fields' and 'manage display' links, when I click on them I'm taken to the 'edit' page. Also, if you have admin_menu installed and just hover on structure/content-type/custom-content-type, a menu with the available edit options appears, but in my case only 'delete' is there.

Searching around I see this is most commonly caused by the 'field ui' module being disabled, but I checked and it's in fact enabled. I disabled/re-enabled it but nothing happened.

Per this post, I also tried enabling all checkboxes at admin/config/administration/admin_menu under the 'performance' tab, flushed caches, and still no result.

I did the site's update for a client, and still have a version of the site on localhost, where all menus work fine. I sent them all files/database so their hosting provider would upload the site and now this issue comes up. I have no access to the database, only the admin pages. What else could be the problem and how could I fix it?

Thank you in advance.

0

Solved. I could get access via FTP and found out there were 2 missing files from the server. After uploading them the problem is fixed.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.