3

I'm facing a strange problem with the Chosen module. I've have 3 term-reference fields added to a content-type.

While editing & adding any nodes of this content-type, Chosen UI interface is applied & working with all 3 fields.

Now, I created a view and exposed the filters for all these three term-reference fields. In the view, Chosen UI interface is applied only to one field and not applied to the rest.

In the settings of chosen module (admin/config/user-interface/chosen) Apply Chosen to the following elements is set to select

These are the Drupal settings outputed by Drupal into javascript:

"chosen":{
  "selector":"select",
  "minimum_single":"20",
  "minimum_multiple":"20",
  "minimum_width":"300",
  "search_contains":true,
  "disable_search":false,
  "disable_search_threshold":"Never Apply",
  "placeholder_text_multiple":"Choose some options",
  "placeholder_text_single":"Choose an option",
  "no_results_text":"No results match",
  "multiple":{
     "field_tags_tid[]":true,
     "field_working_area_tid":false,
     "field_published_in_tid[]":true
  },
  "max_selected_options":{
     "field_tags_tid[]":false,
     "field_working_area_tid":false,
     "field_published_in_tid[]":false
  }
   }
}

What might be the problem? How can I rectify it?

EDIT: Here is something interesting. When I manually enter jQuery('select').chosen() into the browser console, then other two exposed filters (select elements) which were not rendered as Chosen UI elements are now rendered.

Any idea, about what might be wrong with it?

8
  • Just to be sure, are all 3 of your exposed filters using the select widget? Also, do you have any javascript errors on the page?
    – rooby
    Mar 9, 2014 at 4:11
  • @rooby: There are no javascript errors on the page. What do you mean by "exposed filters using the select widget?"
    – claws
    Mar 9, 2014 at 5:04
  • It's possible to have exposed taxonomy filters that don't use a select field. For the ones that chosen is not working for, are they appearing as normal select fields or some other field. I'm sure this probably isn't the problem I just wanted to check.
    – rooby
    Mar 9, 2014 at 5:44
  • While editing & adding any nodes of this content-type, Chosen UI interface is applied & working with all 3 fields.
    – claws
    Mar 9, 2014 at 10:06
  • To reiterate what @rooby asked, are the exposed filters using a select (dropdown menu) element or something else i.e. radio buttons or checkboxes? Unless you're using a module that overrides them e.g. Better Exposed Filters they will be select elements.
    – gigabates
    Mar 9, 2014 at 14:01

1 Answer 1

6
+50

It looks like you have a 'Minimum number of options' setting of 20. I'm guessing the ones that don't display have less than 20 available options. Try setting this to 'always apply' on the Chosen settings form (admin/config/user-interface/chosen).

1
  • I feel like an idiot! I've been struggling with it for almost 10 days now, I've scanned every line of the code from module. Tried with different JQuery versions. But I somehow missed this god damn setting :(
    – claws
    Mar 9, 2014 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.