0

I'm facing some peculiar problems(my devel_themer is also not working). There are multiple versions of jquery included. Its not me who included them, its different modules:

<script src="http://code.jquery.com/jquery-1.9.1.min.js"></script>
<script>window.jQuery2 = jQuery.noConflict();</script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.jQuery || document.write("<script src='/drupal/sites/all/modules/contrib/jquery_update/replace/jquery/1.10/jquery.min.js'>\x3C/script>")
//--><!]]>
</script>

I don't know if any of the following errors relate to problems:

SyntaxError: Using //@ to indicate sourceMappingURL pragmas is deprecated. Use //# instead jquery-1.9.1.min.js:1
Error: http://code.jquery.com/jquery-1.9.1.min.js is being assigned a //# sourceMappingURL, but already has one
SyntaxError: Using //@ to indicate sourceMappingURL pragmas is deprecated. Use //# instead jquery.min.js:1
Error: https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js is being assigned a //# sourceMappingURL, but already has one

should I remove them?

1 Answer 1

1

Try using the jquery multi module. Drupal core relies on specific versions of jquery, but this module allows you to control which environments use which version. https://drupal.org/project/jqmulti

You shouldn't add jquery manually, nor should any modules. Drupal adds its own in core. Your errors may well be related, but that's hard to tell from the info you give. Do you know which module has added this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.