I have a comment form in a panel. The path to the panel is user/[uid].

When I post a comment I am taken to another page where all the comments are shown (user/[uid]/comments.) I do not want this, I want to stay on the same user/[uid] page.

Does anyone know how to do this using the Rules module?


1 Answer 1


A possible "remedy" for this is to use the Rules module (indeed ...). To do so, have a look at my answer to "How to restrict access to a node via node/12 and allow access via a path like content/sometitle?".

Use the rule included there (within "Option 1"), and apply these changes to it:

  • Adapt the regular expression within the "Rules Condition", to make it match your (user/[uid]/comments.).
  • Adapt the "no_access" url to your user/[uid].
  • Probably you don't want to display any message, so just remove that "Rules Action".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.