0

I installed the "Skeleton" theme and found it has a "Broken Skip Link" by using "wave.webaim.org". How can I find and fix where is this "Broken Skip Link"?

You can find this Skeleton demo at "http://demo.drupalizing.com/skeleton"

and the "Broken Skip Link" error at "http://wave.webaim.org/report#/http://demo.drupalizing.com/skeleton/"

enter image description here

1

I use the Skeleton theme. it has:

  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>

But it has no anchor tag for main-content. You should file an issue for the Project on Drupal.org.

You can fix this by supplying a patch to the theme project that alters html.tpl.php or page.tpl.php to include an <a name="main-content"></a> at the top of the content area. You may do this in your own subtheme as well of course simply by modifying the necessary TPL file.

EDIT: Issue created at Drupal.org https://drupal.org/node/2211661

  • Ty @tenken ! Adding "<a name="main-content"></a>" does resolve the error message, however I still dont know where can modify the code you mentioned. which is <div id="skip-link"> <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a> </div> – CocoSkin Mar 6 '14 at 13:46
0

Have a look at https://drupal.org/comment/8551121#comment-8551121 for an explanation and a patch file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.