1

I've tried both the CKEditor module, as well as the WYSIWYG module (with CKEditor library installed). I've configured it all correctly and it should work, but it doesnt. I've also tried changing the CSS options but still nothing.

I'm getting "r is undefined" in the console, but only if I change the text format option underneath where the editor should be.

I'm currently working off localhost - might that be an issue?

  • Working from your localhost won't be an issue. What exactly do you mean by not working though? Are you able to enable the module and just not see the editor appear on fields? Are you able to edit content with the WYSIWYG editor but it doesn't actually format the content appropriately? – jordojuice Sep 5 '11 at 1:30
  • You probably didn't configure it correctly. Maybe some files are missing from /site/all/libraries/ckeditor. Make sure you use CKEditor through WYSIWYG. – ram4nd Sep 5 '11 at 6:44
  • It is all configured properly, including the CKEditor library, as I said. – Mythical Fish Sep 5 '11 at 15:57
  • I am able to see the module, and select CKEditor, however when it comes to editing content there's nothing but white space. – Mythical Fish Sep 5 '11 at 15:58
  • It's eider you have js disabled in your browser or it's installed or configured the wrong way. Can't be anything else. – ram4nd Sep 6 '11 at 7:43
1

Well I finally got it working...

I installed CKEditor module, CKEditor library, and then had to hack the CKEditor library folder by creating new subdirectories with the appropriate files (it was looking for the skin and language files in the wrong directory within the CKEditor library folder)...

I'm using the latest version of everything - why is this happening? I would have thought since this happened to me its happening to everyone else as well!

If anyone else has this problem, ensure you have these files in your /modules/ckeditor/ckeditor/ folder: "lang/en-gb.js" "skins/kama/images/sprites.png" "skins/kama/editor.css" "skins/kama/icons.png"

All these files are just in the root folder by default for some reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.