0

Im using D7.24 I downloaded admin_menu module (I tried also previous releases) but when trying to enable it I can't, and I get this info message in the description module field :

Requires : System (>7.10) (is incompatible with version > 7.x-1.0-beta3) Required for : Administration menu Toolbar style (disabled)

I searched about this problem but I did not found anyone has this problem before!

Thanks in advance

EDIT: This is the info that I get in status report : enter image description here

  • 1
    This question appears to be off-topic because it is about issue in the admin menu module and you have to submit a bug in the module issue queue page. – Bala Mar 13 '14 at 9:42
  • I see no record of admin menu module version 7.x-1.0-beta3 - You should be on 7.x-3.0-rc4, can you confirm you admin menu module version? – rooby Mar 15 '14 at 4:03
  • @rooby: Im using the latest version of admin menu: 7.x-3.0-rc4. This is strange! not :) – Boussetta moez Mar 17 '14 at 10:49
  • That's not strange, but the message "is incompatible with version > 7.x-1.0-beta3" is. – rooby Mar 17 '14 at 10:52
  • I would go and look to see if you have the admin module in another directory, eg, look in modules as well as sites/all/modules etc as it looks like you might have an old version in one directory that is getting picked up before the one you think should be found is actually found. – Jimajamma Mar 17 '14 at 19:10
2

Per this line in admin_menu.info:

dependencies[] = system (>7.10)

The module requires a core version of Drupal greater than 7.10. Currently yours must be less than that.

Drupal core is currently at 7.26; you'd be wise to update ASAP, there have been a number of security updates in recent memory.

  • Thanks for your answer, I added the image of status report, and it tell me that's drupal 7.24 ! – Boussetta moez Mar 13 '14 at 9:57
  • Sorry I think I read your error message wrong (my French is a little rusty :) It seems to be saying that the version of Admin Menu you've got (1.0-beta3) is only compatible with Drupal core <7.10. If you download the latest version of admin menu (1.0-rc4) that error should disappear – Clive Mar 13 '14 at 10:02
  • Unfortunately, this is not working also :( I downloaded the latest version of admin_menu, I cleared the cache, and I get the same message. – Boussetta moez Mar 13 '14 at 10:19
  • Hmmm, sorry but I'm out of ideas it might be worth checking the issue queue for the module in case you can find anything similar. Or try disabling other contrib modules you have one by one to see if you can spot anything that's making it break. Always take a backup first, of course :) – Clive Mar 13 '14 at 10:56
  • 1
    Yes I thought about drush to force enabling it but no luck also, maybe like you said, there is something wrong in my installtion, so I deleted the dependencies in .info file and it works like a charm ;-) – Boussetta moez Mar 13 '14 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.