1

I have practically the same problem as here : https://drupal.org/node/2187443

I've flushed my image style because I edited this image style. Now when I reload the page where the image style should be shown they are missing (404).

What did I missed? shouldn't it be recreated automatically when styles are removed ?

Edit :

I found that images couldn't regenerate if 404 error isn't managed by Drupal. I think its very possible, then I made a change in to my .htaccess file to make Drupal manage 404 errors.

I am now getting the 403 error upon all my files, that are still not loading. :(

Failed to load resource: the server responded with a status of 403 (Forbidden) 

Then I add +w on my files directory recursively to make sure the writing permission available for all to avoid 403 but nothing happens.

  • Clear cache and check your permissions. – niksmac Mar 13 '14 at 15:39
  • To be more specific, make sure your permissions follow Drupal's guidelines drupal.org/node/244924; – kbrinner Mar 13 '14 at 21:31
  • I'm already using this to fix my drupal permissions – jramby Mar 14 '14 at 6:03
0

Problem solved!!!

After checking that Drupal manages itself 404 errors by checking .htaccess file :

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

I had to put this line into my settings.php... This is in the Drupal 7.20 release notes :

$conf['image_allow_insecure_derivatives'] = TRUE;

This thread saved my day.

Wish helps others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.