1

I am using Boost and Cache Expiration. My site generates nodes automatically and adds them via node_save(). I have setup Expire to get triggered on node insert, update and delete and to let the front page and the node page expire (see screenshot).

The problem is now: When the site is under high traffic, the front page does not get expired. When the traffic is low, the expiration works as it should.

I could reproduce this error even locally: While adding a node, I let wget constantly accessing the front page on my local host. As on the production server, the front page did not expire.

My hunch for the reason now is that the following happens within some milliseconds:

  1. When calling node_save(), the new node get only scheduled to be saved but not saved yet.

  2. The cache although, gets flushed immediately.

  3. A new request to the front page is made, it gets delivered and its old version gets cached again.

  4. The scheduled node save operation finally gets written to the database. But it has no effect to the front page, since it is already cached.

Do you think that my hunch is correct? If yes, what should I do? And if no, what could be the reason instead and what should I do?

Cache expiration settings

  • Hm, interesting problem. I'm not too familiar with boost for D7, but in D6 there is a setting called "Overwrite the cached file if it already exits" in the "Boost advanced settings" section. Does that exist in D7 and if so, have you tried that? – berliner Mar 18 '14 at 0:34
  • anther option might be to use the crawler at defined intervals. – berliner Mar 18 '14 at 0:39
  • Just tried to find that option but it seems that it doesn't exist anymore. There's even no "advanced settings" section anymore. :) – Georg Jähnig Mar 18 '14 at 2:25
2

You may try to add the <front> page to the rules action "Clear URL(s) from the page cache":

Rules: Clear URL(s) from the page cache

  • Thank you. I did. As well as domain.com/start Still the same effect. I went down to a lower number of hours as Cache Lifetime, since then it got better, though not resolved. – Funana Apr 27 '16 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.