0

I want to add to the body of a Drupal node (in my case the default article), the google iframe to embed one map

<iframe src="https://www.google.com/maps/embed?pb=!1m14!1m12!1m3! ... </iframe>

I use Drupal 7.26, CKEditor as Wisywig editor with the "Standard Package", and everything is working fine.

What I tried after reading many articles:

  • I set the node to Full Html (of course)
  • I unchecked "Limit allowed HTML tags" in /admin/config/content/formats/full_html
  • I put "Use custom formatting options" to yes in the "Cleanup and Output" section of admin/config/content/ckeditor/edit/Full
  • ... few combination of the above.

What it happens: I edit the article, I insert the html source in the body. I untoggle the source button, everything is disappeared (I go back to source and nothing left).

enter image description here

Note: I don't want to use OpenLayers, I don't want to install modules such Iframe, or SimpleMap, because I just need this map once. It should be working, but my html is still filtered for some reason.

1

Please see dev.ckeditor.com/ticket/11688 for more details.

If you are using latest CKEditor for Drupal module then please go to Modules->CKEditor->Configure and edit your profiles. Each of them has ADVANCED CONTENT FILTER setting which can be disabled/enabled or extended.

NOTE: durring checking it has turned out that relase version for drupal OS module hasn't been updated thus you can't see this setting. For now please use development release which has this feature and is fully stable.

screenshot

  • Thank you, I solved by installing the Full Package on Client Side, but this solution allow me to install back the Standard one. – donnadulcinea Mar 21 '14 at 3:02
1

As results from the discussion in http://dev.ckeditor.com/ticket/11688 it turned out that CKeditor Standard Package don't allow on principle to paste iframes and other html objects, while Full Package allows it. This confused me since I don't expect this difference among packages that should differ only in terms of features provided.

This can be tested at the demo page of CKEditor, while in the Full Package tab you can paste iframe (as expected) in the Standard Package Demo you can't. I used a Google Maps Iframe for the test.

Hence, this problem can be solved

  • As answered by @user27417, updating the module to the dev version and configuring the ACF
  • By installing the Full Package client of CKEditor.

The CKeditor team was very supporting. Thank you.

0

Create a Text Format OR modify text format with these setting(see image) and using that text format use iframe of google map. enter image description here

  • Thanks @Rupesh, but removing all filters doesn't solve. I just discovered that removing the rtf (Switch to plain text editor) let me insert iframes. But I still would like to understand why ckeditor removes iframes when toggling source button. – donnadulcinea Mar 18 '14 at 6:18
  • Check iframe is allowed tag for that text format – Rupesh Mar 18 '14 at 6:20
  • As I said "Limit allowed Html tags" is unchecked. I also added Iframe to the filtered one anyway. Crazy, in another website it works properly. I also well checked file permissions. CKeditor is version 4.3.3. Thanks Rupesh. – donnadulcinea Mar 18 '14 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.