3

Does anyone has issue with mac Xampp localhost? Everything seem fine after I imported online Drupal site and database to Xampp(1.8.2-4) localhost. However, after I hit the login button on the login page( [https://localhost/user][1] ), it gave me "access denied". That's mean I cant login at all.

Best, CocoSkin


it gave me the error message after i run drush upwd admin --password=YOURNEWPASSWORD

~ here is the error message ~

HH5765-122A-M1:~ cocoskin$ cd /Applications/XAMPP/xamppfiles/htdocs
HH5765-122A-M1:htdocs cocoskin$ drush upwd admin --password=MYNEWPASSWORD
Command user-password needs a higher bootstrap level to run - you    [error]
will need to invoke drush from a more functional Drupal environment
to run this command.
The drush command 'upwd admin' could not be executed.                [error]
Drush was not able to start (bootstrap) the Drupal database.         [error]
Hint: This may occur when Drush is trying to:
 * bootstrap a site that has not been installed or does not have a
configured database. In this case you can select another site with a
working database setup by specifying the URI to use with the --uri
parameter on the command line. See `drush topic docs-aliases` for
details.
 * connect the database through a socket. The socket file may be
wrong or the php-cli may have no access to it in a jailed shell. See
http://drupal.org/node/1428638 for details.

Drush was attempting to connect to: 
 Drupal version         :  7.26                                  
 Site URI               :  http://default                        
 Database driver        :  mysql                                 
 Database username      :  test_drupal                           
 Database name          :  test_drupal                           
 Default theme          :  garland                               
 Administration theme   :  garland                               
 PHP executable         :  /usr/bin/php                          
 PHP configuration      :                                        
 PHP OS                 :  Darwin                                
 Drush version          :  6.0-rc4                               
 Drush configuration    :                                        
 Drush alias files      :                                        
 Drupal root            :  /Applications/XAMPP/xamppfiles/htdocs 
 Site path              :  sites/default                         
 File directory path    :  sites/default/files
  • The [https:]//localhost/user looks rather weird, are you sure that you have a local SSL, and your Drupal is installed at your apache root folder? maybe you want to try localhost/<YOUR-SITE>/user – Pan Chrono Mar 20 '14 at 17:59
  • ya, the "localhost/user" is the right url. I imported my drupal on "applications/XAMPP/xamppfiles/htdocs". I also did enable the ssl by using "sudo /Applications/XAMPP/xamppfiles/xampp enablessl" on my terminal – CocoSkin Mar 20 '14 at 18:06
  • try http, set your .htaccess correctly, clear caches with drush – Pan Chrono Mar 20 '14 at 18:50
  • @PanChrono I'm trying to install Drush in my Mac OS. – CocoSkin Mar 20 '14 at 20:31
  • :( it took me a while to install and "drush cc all". However, it still does not allow me to login – CocoSkin Mar 20 '14 at 21:19
1

If you are sure that your password is correct go to the Data base and empty( truncate) Sessions & Flood and all cache(I mean all tables has prefix cache_) tables,finally clear your browser cookie then try to login otherwise(If you are not sure about password) try to reset password programmatically

0

if you have drush installed you can run drush upwd admin --password=YOURNEWPASSWORD. Hope this helps

  • wish i have that installled on drupal – CocoSkin Mar 20 '14 at 18:16
  • 1
    How to get drush working on windows: mikeytown2.drupalgardens.com/content/… Similar things can be done for any OS. Find the php binary, pass in the path to drush, and then pass in the path to the drupal site to drush. – mikeytown2 Mar 20 '14 at 22:15
  • I got error message after using "drush upwd admin --password=YOURNEWPASSWORD". See my edited post on top for details – CocoSkin Mar 21 '14 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.