1

I get this message in Security Review report:

Base URL is not set in settings.php

even though my settings.php code has this:

$base_url = 'https://www.mysite.com';

I cleared caches several times, run CRON, alert message still shows up. I've googled for some time, no luck in finding clues about this. Any help would be appreciated.

UPDATE: If I change to http:// then the message disappears, but my secure login for administration doesn't work. Is there a way to define the $base_url as either http or https?

  • Can you make it //www.mysite.com? – Randell Mar 21 '14 at 5:20
  • Do you have an up-to-date version of Security Review? I've just looked at the code and it doesn't test for http/https. It simply uses PHP's token_get_all() to parse the settings file and look for a left-hand token called $base_url. The protocol shouldn't be able to affect that – Clive Mar 21 '14 at 9:13
  • Thanks @Clive for the helpful info, and yes I have the updated Security Review... seems like this is a very localized issue, I'll consult with my hosting company. – longboardnode Mar 22 '14 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.