1

I have given permission for anonymous users to comment on my site. But the default comment form being displayed does not have a field for email address in it. Also, I have comment notify installed. The email field to be displayed on the comment field should be recognized by comment notify as the email address of the commentor so that it can send notifications. Also, the email field should not be made visible for logged in users. I cannot solve all the three problems at once. Any help will be greatly appreciated.

2

I think you can make this work as follows:

  1. In the Permissions settings via admin/people/permissions, ensure ANONYMOUS USER can View comments, Post comments, and Subscribe to comment notifications

  2. In the Comment Notify settings via admin/config/people/comment_notify, ensure comment notification is enabled for the content type(s) you care about

  3. For each content type you care about, e.g. for Basic page via admin/structure/types/manage/page, expand the Comment settings tab in the vertical menu at the bottom of the page and ensure "Anonymous commenting" is set to Anonymous posters must leave their contact information

  • What I was having trouble was finding the third step. Thanks. I got it working now, but there is also a website field added with the email field which I don't want. Is there any way to remove the website field and display only the email field? – Rana Prathap Mar 27 '14 at 14:09
  • 1
    You can remove the website field by adding the following code to your template.php in your theme directory: function themename_form_comment_form_alter(&$form) { $form['author']['homepage']['#access'] = FALSE; } – rroose Aug 19 '16 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.