0

I wish to migrate my site from one shared hosting server to another. Both servers are with the same company (Heart Internet). I moved the files to the new server, set up a new database on the server, replaced the old settings.php with the contents of default.settings.php to get a default draupal installation up and running.

Trying to migrate the database using either the backup and migrate module or importing the database via phpMyAdmin I get a white screen error on the site i am migrating to.

I have looked up some possible causes and based on what I have read I have:

  • Disabled Devel modules
  • Disabled Clean URLS

I found this helpful page on troubleshooting white screen on death in drupal which recommends adding code to the index.php to get information on the problem.

Following the instructions given there gave me the following error description:

Fatal error: Call to undefined function _date_api_element_info() in /home/sites/MY_DOMAINNAME.co.uk/public_html/sites/all/modules/date/date_api/date_api.module on line 2298

Based on this I assumed that the date module was causing the problem I disabled the date module on the original site and rolled the new site back to the basic Drupal install and imported the most recent databased backup. However I am still getting the same error message.

Both servers are set to execute scripts as PHP 5.3

I can appreciate that this is not an easily issue to reproduce. I would like suggestions as to sensible next steps to try to stop this error from occurring and complete the site migration successfully.

  • So you're saying you get the same error from date module even when you disabled it? Also, are you sure you cleared all caches? And disabled APC for the time of migration (or clear it after every code / module change to make sure)? Last but not least, is this function defined? File transferred properly? – Mołot Mar 31 '14 at 9:23
  • Have you checked this post: drupal.org/node/358793 ? Looks like there is something wrong with your php version. Could you check it by adding a simple test.php file with this code <?php phpinfo(); ?> and access it ? – Matt Mar 31 '14 at 9:31
  • Thanks Molot - I checked and actually there was one component module as part of 'date' that had not been disabled. I disabled this, cleared caches, exported and the import worked ok-ish. Not perfectly as I am now getting other issues which I am now looking into – Paul Trotter Mar 31 '14 at 10:13
  • Thanks for the suggestion Matt. I had been reading similar things about php <5.2 having issues. The working site was set to php 5.3 so i set the new server to 5.3 as well, but this did not solve the issue – Paul Trotter Mar 31 '14 at 10:27
1

Issue solved.

I had not disabled all of the date sub-modules (Thanks Molot for making me double check this). I ensured they were all disabled, cleared caches and was then able to export the database and import it on the new server.

I did get some errors on the new install. Running update allowed me to see that workflow needed updating. Updating workflow and ensuring the right sub-modules were installed (You can't run Workflow Node and Workflow Field at the same time) fixed the other errors.

I was then able to re-enable the date module.

0

I had the same issue and a simple drush cr did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.