1

I am trying to clear all caches on a local install of Drupal (using pantheon aliases):

drush @self cc all

However, when the menu caches are cleared I get this error:

WD pantheon_apachesolr: Error unable to use client certificate (no key found or wrong pass phrase?) connecting to [error] https://index.live.getpantheon.com/sites/self/environments/dev/index/admin/luke?numTerms=0&wt=json on port 449 Creating default object from empty value Pantheon_Apache_Solr_Service.php:514                                                                                    [warning]WD Apache Solr Views: "0" Status: Request failed

The command appears to try to connect to pantheon, but fails. Is there a set up step I might have missed - to cause this error? Or can clearing all caches not be achieved when using a local install alongside the Pantheon platform??

Many thanks in advance, Richard

  • Try without @self, just drush cc all – awm Apr 1 '14 at 16:04
  • Hi awm, good point. Although this still causes the same error. – user2212212 Apr 1 '14 at 16:11
  • Do you have the entire database on your machine? It looks like it has the pantheon_apachesolr module enabled. Try to disable it and try again. drush dis pantheon_apachesolr -y then drush cc all – awm Apr 1 '14 at 16:13
  • Your specific error message is related to certificates for Pantheon's servers. It seems that Pantheon support would therefore be a better place to direct this question. – greg_1_anderson Apr 1 '14 at 17:53
  • Thanks for the comments, it does appear the only way to solve this is to disable the mentioned modules. This was echoed from the Pantheon support team. – user2212212 Apr 3 '14 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.