A localised Drupal 7 site I'm working on has a navigation menu along the top. Each node is provided with a menu link with a given weight. Nodes are translated into three (non-English) languages (the admin language is English). The nodes show on the menu correctly depending on the current language.

Whenever I edit a node (eg edit the title, body) and click Save, its links disappears from the menu.

The same thing happens if I edit a node but don't actually change anything, then click Save.

I can re-enable it by:

  1. Edit the node again
  2. Untick the menu link
  3. Save
  4. Edit the node yet again
  5. Tick the menu link (re-filling the title/weight)
  6. Save again


  1. Go to admin/structure/menu/manage/main-menu
  2. All the other menu links are enabled, but the recently saved is not and has "(disabled)" after its name
  3. Tick the box to re-enable
  4. Save configuration

But how can I stop menu links from being disabled when a node is edited?

2 Answers 2


Here's a quick fix:

  1. Download version 1.7 of i18n.

  2. Unzip it and find the folder named i18n_menu

  3. Go to your site's modules directory (could be /sites/all/modules/) Find the folder i18n

  4. Replace the subfolder i18n/i18n_menu with the version from version 1.7 you downloaded in step 1

You can also check this bug report: http://drupal.org/node/1905268

  • Thanks for the suggestion. Unfortunately if I do this, links don't disappear after edits, but instead I see all links from all three languages instead of just those for the current language. Any ideas?
    – Hugo
    Apr 3, 2014 at 12:51
  • I checked the bug, and its parent bug has been fixed and released in the latest dev version. Installing that fixed it. Thanks for the pointers!
    – Hugo
    Apr 3, 2014 at 13:12

It's a bug in the latest version 1.8 of i18n Martins Bertins' patch fixed this for me.

But its parent bug has been released in the latest dev version, and installing that fixed it as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.