2

I'm trying to install memcached and having no luck getting the site to run in local development using OS X 10.9 Mavericks. The homepage loads, but that's it. Everywhere else, I get this error:

Fatal error: Maximum execution time of 180 seconds exceeded in /Users/me/Sites/mysite/modules/field/modules/field_sql_storage/field_sql_storage.module on line 352

I get the error at the same point, no matter what the max_execution_time is set to.

I'd love to get this working, but I'd be content just to uninstall the whole mess. I can't seem to get the site working again even after I attempted that.

Some additional bits of information:

  • memcached and libmemcached are installed via homebrew.
  • The memcached daemon is running.
  • The memcache and memcache_admin modules are enabled
  • memcache_admin is still giving me statistics at the bottom of the page.
  • The Drupal admin seems to work just fine.
  • The machine is a 2013 Retina MacBook Pro with a 2.4GHz i7 and 16 GB of ram.
  • Here's the memcached info from phpinfo()

enter image description here

Only a very small bit of the page loads whent his timeout happens. Just a menu and a few small things from the top of the page. The memcached statistics load in the menu that's highlighted. There's about 20,000 rows worth of statistics.

enter image description here

  • Do you have drush? if so try to install it. It will helpe debuging. If it is installed, try drush cc all. And when you increase the max execution time, does still fail after 180s? – awm Apr 5 '14 at 21:47
  • Yep, I've tried clearing the cache with drush, but no luck. I've increased the execution time to 300s and it still fails with the same message. – Thrillho Apr 6 '14 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.