1

I installed the CKEditor in Drupal 7, following the steps in the documentation. I set up the right permissions and the text options and I cleared the caches, but when I want to add or edit some content, I have only the plain textarea.

However, when I navigate to Administration » Configuration » Content authoring » CKEditor. and edit the Filtered and Full HTML, the WYSIWYG editor shows up as it should when I expand the Editor Appearence tab, so I assume it's well installed.

What I find peculiar is that when I navigate to Administration » Structure » Content types, select a content type and click manage fields and edit for the body field the area just below the text: "The default value for this field, used when creating new content." is still the old textarea. I don't find any option to change it, as if the WYSYWYG editor wouldn't exist.

Anyone has an idea, a solution? Is it something I miss here?
Thanks a lot for your help.

2

It sounds as if you've selected "Plain text" instead of "Filtered text" as your default text processing option. To change this, navigate to Administration » Structure » Content types, select the content you experience problems with and click manage fields and edit on the body field (and other text fields you want to use the wysywyg editor). Make sure that the preset text format for that text field is set to to one of the formats configured for wysywyg (e.g. Filtered HTML).

To make sure that Filtered HTML is selectable, you need to make sure that the setting for "Text processing" is set to Filtered text (not Plain text):

screen dump

Press Save settings after changing this.

Make sure that when you create content, a text format that is set up to use use WYSYWYG (e.g. Filtered HTML) is selected. The screen dump below shows how the pull-down menu immediately below the text field for content should look like:

screen dump

Other thinks to try when debugging a CKEditor setup:

Here are some more tips on debugging a CKEditor setup. They probably don't apply to you, but may help others that arrive at this question while searching for a cure for CKEditor blues:

  1. Clear the cache:

    Remember to clear the cache after you've changed any setting that has something to do with wysiwyg. Not clearing the cache is probably the most common source for CKEditor not showing up as you would expect.

  2. Check out that roles are configured correctly:

    Navigate to your text formats: Administration » Configuration » Content authoring » Text formats and ensure the roles are configured correctly.

    • Add the roles you want to use wysiwyg to Filtered HTML and Full HTML.
  3. Check out that profiles are set up right:

    Navigate to your ckeditor profiles: Home » Administration » Configuration » Content authoring » CKeditor

    Go to the profiles, and verify that the text formats for the profile are set, and the editor appearance is set properly.

    • Under Basic Setup, check the text formats that apply
    • Under Editor Appearance, set default state to enabled, and show the toggle.

PS: For a secure use of WYSYWYG, I recommend using a custom text format filtered with the WYSIWYG Filter. How you do this is described in this tutorial. However, first get it working, then start tweaking to make it secure.

  • Thanks for your help. I checked all these settings and they are right, I have 'filtered html' selected and the permissions are in order. What I don't understand is why the default presentation for the body of each content type ("The default value for this field, used when creating new content." ) is still the old textarea. I don't find any option to change it, as if the WYSYWYG editor wouldn't exist. Thought I checked it in the Editor Appearance, and it's properly installed. I don't know what else I could do here... – maxianna Apr 7 '14 at 9:55
  • Thanks for your help! Actually I debugged it, finally..:) I got an error message and I realized that it was looking for a path which actually didn't exist in my Drupal files...I had to change the path settings in Ckeditor- edit Global Profile, and now it's working!! – maxianna Apr 7 '14 at 14:10
0

Sometimes, when I create a WYSIWYG field, and doesn't load the editor I do the following:

  1. Check the Enable by default for the Filtered HTML profile:

Home » Administration » Configuration » Content authoring » Wysiwyg profiles » CKEditor profile for Filtered HTML enter image description here

  1. Set the Text processing in the Content Type settings:

Home » Administration » Structure » Content types » Article » Manage fields Content enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.