Just now I migrated my website to server machine. I noticed that website is not able to send any email. It is showing "Unable to send e-mail" error.

Below is the screenshot of the error- enter image description here

I can see some directory permissions error in status report at admin/reports/status. Are these related to each other?

up vote 4 down vote accepted

It's very likely that your new server does not allow mail to be sent from the web service. This could be because it blocks the SMTP port, or because it doesn't allow PHP to use mail(). You should be able to contact their tech support to ask. If not, you can try uploading your own PHP script that uses the mail() function and see what errors it gives you.

IMO, this is a good thing... web servers shouldn't be sending emails for a variety of reasons.

I would recommend using something like this: https://drupal.org/project/smtp

It will let you send email through a real email account, of course you'll have to make sure there's not a block on the port it uses.

  • Hey I can see some directory permissions error in status report at admin/reports/status. Are these related to each other? – Ravi Joshi Apr 7 '14 at 14:00
  • I doubt that they are, however you may see more detailed errors if you're able to properly log the error reports. You may want to correct that issue and see if any errors related to mail show up. – jdu Apr 7 '14 at 14:22
  • Can you please tell me the locations of error log files? I am using Apache server in Ubuntu 10. – Ravi Joshi Apr 7 '14 at 15:15
  • 1
    I think your server logs will be at: /var/log/apache/error.log ... but if they're not there, you may want to post to an Ubuntu forum for better help. – jdu Apr 7 '14 at 15:26

Following settings worked for me on windows.

Download and enable SMTP Authentication Support module

If You use Gmail to set up STMP follow these steps:

SMTP server: smtp.gmail.com

SMTP port: 465

Use encrypted protocol:Use SSL

SMTP Authentication -- Your gmail User Name and password

Leave the other options by Default

  • Thanks Nayana, it was resolved long back but I truly appreciate your answer. – Ravi Joshi Dec 7 '16 at 13:58

Use SMTP module.

Do not forget to check Access for less secure apps. It should be Access for less secure apps enabled.

https://www.google.com/settings/security/lesssecureapps

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.