0

In another question I was searching for a module that provides a simple shopping cart and checkout process (Is there a simple shopping cart and checkout process module?).

I have found this simple module called Basic Card.

I am running Drupal 6.x while this module is written only for Drupal 7.x.

Is it possible to run a Drupal 7.x module on a Drupal 6.x installation?

3

No, it's not generally possible without back-porting the code.

The API is very different between Drupal 6 and 7. A few things have remained the same, so it's theoretically possible that a module for one version might work as-is in the other version, but generally speaking, it's not possible.

For a proper idea of the task ahead of you, take a look at Converting 6.x modules to 7.x. Not a trivial task, unfortunately.

I just had a quick look and the specific module you've mentioned definitely won't work in Drupal 6, it would need to be re-written.

| improve this answer | |
1

The short answer is "no".

The APIs has changed, and this means that a lot of function calls is generate errors that will make your site useless.

A slightly longer answer is "maybe, if you're willing to do some work".

Many Drupal 7 modules doesn't use critical functions that only exists in Drupal 7. This means that you can "downgrade" them from Drupal 7 to Drupal 6 by rewriting the hooks and other functions that calls the Drupal API to conform to Drupal 6. I've done it myself with a couple of modules, and if you're familiar with both sets of APIs, it usually doable.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.