0

I recently upgraded from Drupal 7.25 to 7.26 in maintenance mode. The upgrading did not have any errors.

Now when I go to the homepage I get an Internal Server Error.

I added an echo statement to verify that bootstrap.inc was executing.

I haven't been able to log any PHP errors.

This is the first part of my .htaccess file (the other part that includes rewrites isn't allowed by Stackexchange due to links)

    # Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(\..*|Entries.*|Repository|Root|Tag|Template)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Multiviews creates problems with aliased URLs and is not needed for Drupal.
Options -Multiviews

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Force simple error message for requests for non-existent favicon.ico.
<Files favicon.ico>
  # There is no end quote below, for compatibility with Apache 1.3.
  ErrorDocument 404 "The requested file favicon.ico was not found.
</Files>

# Set the default handler.
DirectoryIndex index.php index.html index.htm

# Override PHP settings that cannot be changed at runtime. See
# sites/default/default.settings.php and drupal_initialize_variables() in
# includes/bootstrap.inc for settings that can be changed at runtime.

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_flag magic_quotes_gpc                 off
  php_flag magic_quotes_sybase              off
  php_flag register_globals                 off
  php_flag session.auto_start               off
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_flag mbstring.encoding_translation    off
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On

  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600

  <FilesMatch \.php$>
    # Do not allow PHP scripts to be cached unless they explicitly send cache
    # headers themselves. Otherwise all scripts would have to overwrite the
    # headers set by mod_expires if they want another caching behavior. This may
    # fail if an error occurs early in the bootstrap process, and it may cause
    # problems if a non-Drupal PHP file is installed in a subdirectory.
    ExpiresActive Off
  </FilesMatch>
</IfModule>
8
  • You need to find out what the specific error is, without that we can't help. If it's not a php error then check your apache logs – Clive Apr 8 '14 at 20:45
  • It's not listed in my apache error logs (at least the one available in Cpanel). – Aaron Kreider Apr 8 '14 at 20:54
  • Looks like it is stuck in maintenance mode (it didn't say this in firefox even with caching off - I needed to open a new private tab to get it). This is good news as I can try to fix it! – Aaron Kreider Apr 8 '14 at 20:57
  • When I log in as the admin user it gives me a blank page. No error message. – Aaron Kreider Apr 8 '14 at 21:03
  • Watchdog log says: "Notice - Undefined index: adaptivetheme. function drupal theme_initialize() %files /home/energy/public_html/drupal/includes/theme.inc %line 100 severity level 5" – Aaron Kreider Apr 8 '14 at 21:14
0

Always run the update script each time a module / the site is updated.

IE: site.com/update.php

It triggers the update hooks in the modules and lets them deal with any db type changes.

After that flush the Drupal caches (admin/config/development/performance/) to clear out any old references.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.