3

I have a body field (Text field with summary) with WYSIWYG CKeditor enabled.

However, the "summary" part of the field lacks a WYSIWYG editor.
How can I enable it?

3
  • Under your content type -> manage fields for the summary field you can enable text processing to be filtered text (user selects input format).
    – zarsiwala
    Sep 9, 2011 at 17:53
  • @zarsiwala, you should post this as an answer to the question; it'll help your reputation and the organization of the site.
    – areynolds
    Sep 9, 2011 at 20:23
  • Here's a recent blog post that solves this problem: Drupal 7: How to Add a WYSIWYG Editor to a "Text with Summary" Field Feb 13, 2012 at 12:20

5 Answers 5

4

The WYSIWYG module's logic acts on text fields with input formats, if you want to explicitly target a form element by its ID you can use the CKEditor module instead.

2

Under your content type -> manage fields for the summary field you can enable text processing to be filtered text (user selects input format). Hope that helps.

1
  • 1
    It seems to refer to the main field, not to the summary. At least, I have it already set to be filtered and have the WYSIWYG editor only in the main field (not in the summary). Sep 10, 2011 at 16:44
2

I had created my own summary field in CCK. I use the CKeditor and this only worked after I realised I had to configure the field as a multiline text area and not as a single line text field.

0

I just tried WYSIWYG module version 7.x-2.x-dev with CKEditor (the editor, not the Drupal module), and it actually worked -- the summary field now displays with a wysiwyg editor instead of the plain textarea.

0

If you are using the wysiwyg module you can enable/disable this in the wysiwyg profile settings. It’s in the fieldset at the bottom: «Basic settings - Enable on summary fields».

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.