3

I have simple Image field, its file path is set to field/image so when you upload a file, its path is something like /sites/default/files/field/image/image.jpg.

But when I create content and upload the file, first of all, the thumbnail preview doesn't show up and when saved, the image is not loaded, because for some reason it's calling a wrong path of sites/default/files/styles/large/public/field/image/image.jpg.

But why? Why that path? There's no such path. Who is calling the wrong URL? It should call the correct path where the picture was uploaded and that's /sites/default/files/field/image/image.jpg.

I've tried using "Original Image" for the image field display, instead of the "Large" style, but no matter what I use, /styles/large/public/ is added to the URL.

Permissions are correct on the /sites/default/files folder (the original image is uploaded successfully), there are no related errors in the dblog report, and there's no problem with GD/Imagemagick in the status report.

What could be adding the extra part to the image URL?

  • Also I noticed even if it all has 777 permissions, it doesn't upload any image to sites/default/files/styles/thumbnail/public/ or any other image style dir/public/ so it obviously doesn't load it too. So all paths/dirs has 777 perms except /default/ has 555. – Optimus Prime Apr 9 '14 at 16:15
  • Just to clear it up, there wouldn't be an image uploaded to the /styles folder. If the file doesn't exist when it's requested, Drupal generates (or at least attempts to generate) the file and serve it straight back to the client. For subsequent requests the file exists, so the generation isn't necessary. It seems you have multiple problems: 1, the derivative images aren't being generated, and 2, the paths for <image> tags are somehow being re-written – Clive Apr 9 '14 at 16:19
  • So what causes that? – Optimus Prime Apr 9 '14 at 16:26
  • For the image styles check your server error logs, if there's nothing in there I'm not sure what to suggest. For the other problem, check custom/contrib modules that might be to blame (disable them methodically until the problem is fixed). But it would be worth fixing the former problem first, it might also fix the latter – Clive Apr 9 '14 at 16:36
1

You might simply be editing the wrong "display". Happened to me :)

If you have the Display Suite Drupal module installed, node types can each have several option sets (called "displays") how to display their fields, and a template or view then selects one of them to show the node. With the Taxonomy display Drupal module, the same is possible for taxonomies.

In these cases, you might simply be trying to adapt the image style setting in the wrong display. Check if you have a second line of tab-like options (starting with "Standard") for either nodes or taxonomies. In that case you have multiple displays for this node type / taxonomy, and you have to configure the image type for the right one.

You'll have to visit one of these admin menu items to check for displays:

  • "Structure → Content Types → [your content type] → Manage Display"
  • "Structure → Taxonomy → [your taxonomy] → Manage Display"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.