2

I am building a Drupal 7 site using the Metatag module.

I know that on the settings of the module there are many tokens, and that's great.

For example, the title under 'Global -> page title' is: "[current-page:title] | [site:name]".

Here it's great and I like that the "|" between the words.

But, When I am on my home page, I see that my site name the browser tab is

Site Name |

In all the metatag settings, and in the site information settings I didn't found any token that looks like "[site:name] |".

Does someone knows why my site name is "Site Name | "?

2

So by default, the module sets up all pages to use "[current-page:title] | [site:name]" and then for the front page it uses "[site:name] | [site:slogan]".

Now I am assuming you do not have a slogan set for your site, which is why it appears like "Sitename | ".

If you navigate to admin>configuration>site information, you will probably see the site slogan box is empty.

So you have a few options..

  1. Add a slogan to your site
  2. change the tokens for the front page.

to change the tokens for the front page, go the the Metatag config page and expand the "Global: Front page" field. You may need to click override to configure it to something other than default.

Click edit to edit the Global Front Page settings. Then remove the token you dont need and the seperator "|".

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.