1

I have a BOA installation where I accidentally run the command drush self-update. This overrided the aegir-comparible drush with a newer version. When I realized the issue, two days later, I replaced the new drush with old one (4.6-dev), found in the backups. The issue I am facing is that the tasks in the Aegir queue have stopped running. They give the message that they should run in the next cron, in about a minute, but then nothing happens. It keeps telling me that the last cron was run two days ago.

I have tried sudoing as Aegir and running the following:

drush vdel hosting_queue_cron_running -y in case a semaphore is left, but this gives the message hosting_queue_cron_running not found.

/var/aegir/drush/drush.php '@hostmaster' hosting-dispatch --debug and it runs fine, which means that the drush kicks the cron, but for some reason it doesn't reach Aegir

I tried to run barracuda up-stable in order to recover .drush, but it didn't recover it. I also tried to clean cache and rebuild registry. The time of the server is correct. Could you suggest some way to further debug the issue?

  • Your log shows the system cron starting hosting-dispatch? – Herman van Rink May 27 '14 at 14:04
1

I found the solution. The problem occurred due to incomplete barracuda + octopus upgrade. One has to run the following commands to finish update

 barracuda up-stable
 octopus up-stable all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.