0

Not sure if this is issue of the Title module which I have enabled, or just a bad configuration.

To reproduce:

1- Create a content type: My content and checked Enabled, with translation

2- Create a english node with title: My english node title. Save

3- Create a translation for that node to french with title: My french node title. Save

4- Now(after I saved the french node) if I go to edit the english node the title field is empty

It happens in the other way too. If I edit and save the english node and then I go to edit the french node the title field is empty

How can I trace this? It seems a bug to me, but not sure.

1

Do you want to manage your content type translation at node level or field level ? You can have a mix of both on the same site if needed, for different content types, but don't mix up within a content type.

If you choose "basic" node translation for content type A, you won't need the Title module, so if it's enabled/in use for content type B, just don't "replace" (admin/structure/types/manage/content_type_A/fields/replace/title) the built in node title of A by a field.

Then when you translate a node from node/xxx/translate then node/add/content_type_A?translation=xxx&target=lang , everything should be ok.

Read also Gábor Hojtsy explanations which are still valuable about translation settings, or Randy Fay Field translation: First steps

1
  • Since I was not using field translation I just disabled the entity_translation module and the problem was gone. Maybe a conflict between title and entity_translation modules. – chefnelone Apr 13 '14 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.