0

I am migrating a Drupal 7 project from one PC to another and I did the following steps

1) Copy pasted the root folder into D:\XAMPP\htdocs
2) Imported the database of that project into phpmyadmin (had to increase max_file_uploads to 20 in php.ini)
3) reset admin password by referring https://drupal.org/node/1023428
4) updated the password in settings.php
5) cleared cache in the imported db (by deleting the content of cache and cache_* tables)

Now I am able to login but the admin panel is blank, When I click Dashboard, Content, Structure, Appearance etc. nothing appears

No error is console.

PS: this is the first time I am using Drupal, so in-depth instructions is much appreciated

Edit

After @Randell's suggestion I had set display_errors to on and error_reporting to E_ALL. Still no error appears anywhere

Edit
From watchdog the last two rows;

Second-Last row

uid : 1
Message : Session opened for %name.
location : http://localhost:81/mysite/user
referer : http://localhost:81/mysite/user

Last Row

uid : 0
Message : Attempting to re-run cron while it is already running.
location : http://localhost:81/mysite/users/admin
referer : http://localhost:81/mysite/user

12
  • How did you cleared the cache in the imported db? by truncate cache_ tables? Commented Apr 15, 2014 at 5:59
  • I used delete from table_name query
    – user28156
    Commented Apr 15, 2014 at 6:01
  • 1
    Make sure you have display_errors ON in your php.ini so you can see the error messages instead of a blank page.
    – Randell
    Commented Apr 15, 2014 at 6:02
  • @Randell, Did that now, not seeing any errors
    – user28156
    Commented Apr 15, 2014 at 6:05
  • 1
    And make sure error_reporting is set to E_ALL. Restart the server after the changes to php.ini.
    – Randell
    Commented Apr 15, 2014 at 6:08

2 Answers 2

0

Most of the time it is the memory_limit setting in your php.ini. Drupal 7 needs a bit more memory and depending on how many modules you are using, it must be set to a higher value. 64M or 128M should be enough for moderate sites.

1
  • It is set to 128M and is working in the PC the project was imported from
    – user28156
    Commented Apr 15, 2014 at 7:24
0

Increase PHP memory limit

If you need more than 128M:

Add the line ini_set('memory_limit', '512M'); to your [Drupal 7 root]/sites/default/settings.php file.

check php_value memory_limit in php.ini