0

I have drupal 7 site hosted on bluehost.

After I changed the admin password, I got an error. I then tried to access the site, and I was able to do that, but it was very slow.

Now, I can't access the site as an administrator. It becomes even more weird: If I delete all history and cookies from the server, I can access the site; I can also login as an authenticated user.

When I try to log in as administrator, I get a white page or a "500 internal server" error. (It depends on the browser; I tried Chrome, FF and IE.) After I do that, I cannot access the site even as guest or authenticated user; only when I delete all the history and cookies, I can access the site as guest or authenticated user.

How can I fix this?

This is the error log the bluehost Representative gave me:

[15-Apr-2014 14:48:49 Europe/Helsinki] PHP Fatal error: Call to undefined function intel_path_filter_type_to_arg() in /public_html/includes/menu.inc on line 814

Is it possiable this module has something to do with the issue? https://drupal.org/project/intel

I think I disable the google analytic api module. Maybe the problem is related to one of the Drupal SEO modules?

I am really not sure, and cannot connect my site..

Yesterday the site worked great! Restoring the site to yesterdays backup did not help - this is the weirdest thing!

6
  • i guess no way to use drush ? if not, try emptying the cache tables and session table
    – mojzis
    Apr 15, 2014 at 17:57
  • @mojzis thank you for your help. Can you please advice how to do that?
    – EB84
    Apr 15, 2014 at 18:01
  • either run command truncate table sessions, truncate table cache_bootstrap (and so on), or try doing the same via some web interface - do you have phpmyadmin ?
    – mojzis
    Apr 15, 2014 at 18:17
  • @MPD it was not server problem. it was the drupal.org/project/intel module that cause that problem. I had to disable it from the myphpadmin, and clear cache and session from my myphpadmin with mysql query. Please reopen so I can post an answer.
    – EB84
    Apr 16, 2014 at 7:51
  • @EB84 I reopened this to see that your answer it. However, problems solved by clearing cache or similar are likely to be closed, as they are unlikely to help future users.
    – mpdonadio
    Apr 16, 2014 at 11:28

1 Answer 1

1

The problem was related to one of the two below (or both):

  • The error from the intel module
  • The session cache / cache

Currently the site is live and working great, but the Intel module is active currently and I don't know if to disable it or not.

The second thing we did (me and the nice guy that helped me) is to clear the cache and sessions cahce - which was problematic for me since I did not had access as admin. We used update.php after allowing every user to access it on the setting.php file (changed false to true), and clear the cache through the mysql query on the 'my php admin'.

Here are the steps:

  1. enter my php admin
  2. choose database
  3. go to mysql tab
  4. on the query: UPDATE system SET status='0' WHERE name='intel';

  5. then need to flash the cache - run the query:

TRUNCATE TABLE sessions;
TRUNCATE TABLE cache;
TRUNCATE TABLE cache_bootstrap;
TRUNCATE TABLE cache_block;
TRUNCATE TABLE cache_field;
TRUNCATE TABLE cache_form;
TRUNCATE TABLE cache_image;
TRUNCATE TABLE cache_menu;
TRUNCATE TABLE cache_page;
TRUNCATE TABLE cache_path;
TRUNCATE TABLE cache_update;
TRUNCATE TABLE cache_views;

I will be happy to get feedback on this solution. The site is currently working - so problem solved. But, I don't know if I still can't disable the intel module and if I can change the admin password. I don't want to cause the problem again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.