I'm having a permissions issue with organic groups. I can get to the OG Node permissions page and set general OG permissions there, and have given administrative member full permissions, but when I go to add or view the existing people, I get the "You are not authorized to access this page" message. For example, "/group/node/[nid]/admin/people/add-user" gives me the not-authorized message.

I've tried all combinations of the "Group roles and permissions" and content visibility settings, but no changes. It just doesn't make sense that user 1 can be blocked out like this, or any user with the Drupal administrator role. I'm also seeing this on my local system, with all content nodes having been created by user 1, which is also a member of every group.

I should point out that I can access the OG People, Add People and other pages for the top level groups, as well as for other group content that's marked as both groups and group content.

Is there an additional setting that I need to check, or is there a combination of settings I need to have to be able to edit the groups' memberships?

  • I seem to recall that this was a bug-like problem. Which OG version? Apr 15, 2014 at 20:37
  • @KariKääriäinen, Organic groups 7.x-2.5, although I just noticed my OG Menu is 7.x-3.0-rc4. You don't think there is a compatibility issue, do you? Someone pointed out that it may not be an actual permissions issue, but that the page doesn't even exist. I don't know why it wouldn't, since it does for the other content types. Any thoughts on that?
    – Jav
    Apr 16, 2014 at 13:53

2 Answers 2


I've experienced something similar after changing the machine name of the group content type - the og_role table column group_bundle is not updated. Rebuilding the table by uninstalling, reenabling and reconfiguring the Organic groups access control module was necessary


The issue was that the og_role table was missing records for the content type in question. I needed to insert a record with the gid set and the group_bundle field set to the content type, then 3 more records for that content type with the name set to one of each of the following: non-member, member, administrator member.

Alternatively, it seems that just removing all OG fields from the OG Field settins page and then reading them also solved the issue. I'm not sure how the data became corrupted, but it sure would have been nice if OG was smart enough to detect the missing data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.