0

When going to node/add/my-content-type there is only a field for editing the title. There are body and FileFields attached to this content type but they are not being displayed until after I click save.

The content type is an OG content type though I am not sure this has anything to do with the issue. I tried toggling strict node access but it didn't help.

Preview is disabled.

  • This is not a standard Drupal way of working. So you have some kind of bug or misconfiguration. Sadly, it's not possible for us to debug your site, and you have to admit that the amount of information you gave us is pretty low. And we don't know the context you do. Examine everything that interacts with your field permissions. Especially things that changed between the moment it was working OK and the moment it started working as it works now. Oh, and certainly see watchdog and error.log. And somewhere there should be your answer... – Mołot Apr 16 '14 at 21:48
  • No problem. I suspect it is related to permissions as well since this is not occurring for the super user account. I've got some custom code that use hook_node_access that I will double check that I just remembered about. – Parag Apr 16 '14 at 22:56
0

I disabled the Organic Groups Field Access module and the missing fields appeared.

Related to the OG issue: https://drupal.org/node/1743332

In summary, for some users, disabling/re-enabling this module while clearing the cache resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.