We have our site hosted on our Virtual Ubuntu 12.0 LTS. I am converting it to HTTPS. We are using Secure Login so that anonymous sessions are via HTTP or HTTPS and authenticated sessions only via HTTPS.

When I enable /var/etc/apache2/sites-available/site-ssl ->

On IE, I get this message "Only secure content is displayed" Click here to show all content for every page we navigate to. When I accept to show all content, the website renders on IE 11.

The CSS is not being picked up at all on a chrome browser ( Version 34.0.1847.116)

enter image description here

I have attached the screen of the site. You will see the menus are not in place. The flex slider images are one below the other.

Any ideas or help to fix this is appreciated !

2 Answers 2


You get this message from MSIE because the page has a mixture of secure and insecure content.

The culprit is usually inline/embedded content (images, iframes, javascript, css, etc.) that originate from a non-secure URL. Chrome just refuses to load it, causing the error you see To fix it, you need to locate those elements of the page, and replace them with secure versions.

To locate for these elements of the markup (unless they are obvious now that you know what to look for), use FireBug (requires that you use FireFox instead of MSIE/Chrome) or just press CTRL+uin MSIE to analyze the markup. In the markup, search for inline/embedded content hyperlinked with URLs starting with http: (instead of https:).

If all your links are internal (i.e. pointing to stuff below the webroot of the same server), you can eliminate the problem by dropping the scheme element of the URL (as suggested in a comment below by @JohnathanElmore).

In other words: if your server is example.com and you currently have the following URL reference as part of your theme:


you should replace it with the following:


or even:


I can't tell you exactly how to go about making these replacements without knowing what you can and cannot do on your site. (If it was my site, I would simply edit the theme templates and clear alll caches. But I've no way of knowing whether this option is available to you.)


Thank you all for all your responses. The issue was fixed by commenting on the base_url specified in the settings file.

  • Hello and welcome. Please post self-answers as neat explanations, something that will be easily usable by others with similar problem.
    – Mołot
    Commented Apr 21, 2014 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.