I have a Drupal 7 installation and several admin pages are incredibly slow and time out after 30 seconds. I've tried several things without success:

  • APC is enabled
  • innodb_buffer_pool_size is set to 100 M
  • No unused modules are enabled. I still have 155 modules enabled, for localization, commerce, captcha, questions & answers, etc.
  • Standard cache is enabled and JS/CSS compression enabled. Memcached not being used.
  • Drupal 7, latest version

Even with that, the site is still really slow and there are pages that won't open (time out). For example, installing a module will always fail the first time. Accessing the settings of the Language Selection Page module will always fail, and so on. Any recommendations other than increasing the timeout?

I'm using WAMP.

UPDATE: The time out error shows it takes a while in this function mainly: drupal_flush_all_caches( ) ..\system.admin.inc:1766

Sometimes in other functions too.

  • Please specify which admin-pages are slow. Sometimes time outs are due to failing outgoing network connections (e.g. for update-status checks). Update: sorry, ignore me, did not read the question to the end...
    – znerol
    Apr 19, 2014 at 10:30

2 Answers 2


If you can profile your site that's always helpful. https://drupal.stackexchange.com/questions/724/why-is-drupal-7-so-slow

https://groups.drupal.org/node/210683 - Older post but some patches have still not been committed.
https://groups.drupal.org/node/415883 - Speedups for the DB layer (caches mainly).

Because of windows checkout this post and this group


After researching a bit more, I think I was able to improve its performance a little bit.

I've changed several variables in MySQL. Some are not recommended really (the first one mainly), but as I'm in development it helps:

  • Set innodb_flush_log_at_trx_commit = 0 (Source)
  • Increased query_cache_size and query_cache_limit
  • Increased innodb_buffer_pool_size
  • Changed semaphore table to memory by executing this script


  • Disabled the Update manager module (not sure if it helped)
  • Uninstalled the Content Translation (and dependent modules) as I was using Entity translation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.