0

I have this error message:

The specified file temporary://fileYU5WGQ could not be copied, because the destination directory is not properly configured. This may be caused by a problem with file or directory permissions. More information is available in the system log.

I know it's a folder permission problem. But I can't figure out which folder is the cause.

In sites/default/files I have these three folders, all of them with permission set to 777:

tmp

temp

temporary

Then I don't know where is the problem?? I attached a image capture of the sistem file setting: capture

3
  • do you have any sub-folder within this folders? Sep 12, 2011 at 10:14
  • no folders inside temp
    – chefnelone
    Sep 12, 2011 at 10:17
  • do you transfer your drupal from another server? Sep 12, 2011 at 11:31

1 Answer 1

1

Did you check what user is the owner of each of your folders in question ? Use chown username:groupname to change owner/group of a folder.

3
  • You hit the point. It is a Owner a Group problem. When drupal create a folder in the remote folder it get Owner: 20003 y Group: 20003 which are Apache settings. How do I tell Drupal to give FTP protocol to the created folders, I mean Owner: 30050 y Group: 30049?
    – chefnelone
    Sep 13, 2011 at 8:29
  • You cannot change folder permissions/ownership directly in drupal unless you use a module like Take Control without php code. The best is to change folder permissions in unix/linux shell or via CPanel, DirectAdmin or ask your host provider. In shell you use command: chown 30050:30049 foldername You can also try to change using your ftp client or directly via php commands, for example: <?php $file_name = "your_filename.php"; $path = "/your_folderpath/" . $file_name; $user_name = "your_username"; chmod($path, 0777); chown($path, $user_name); ?>
    – LLub
    Sep 13, 2011 at 9:48
  • thanks, I guess I need to go deeper in this since I´m having lots of permissions issues.
    – chefnelone
    Sep 14, 2011 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.