3

I'm trying to re-index all my products on my Drupal commerce website. When I do so, I get the following error message:

An AJAX HTTP error occurred. HTTP Result Code: 500 Debugging information follows. Path: /en/batch?id=130&op=do StatusText: Service unavailable (with message) ResponseText:

When I go to watchdog it shows me this error:

EntityMetadataWrapperException: Unable to get the data property status as the parent data structure is not set. in EntityStructureWrapper->getPropertyValue() (line 438 in /sites/all/modules/entity/includes/entity.wrapper.inc).

I tried finding out if there were any specific products or entities with their status not being set. When I run the following query in my database, it shows me that there are no products without status. (They all show up with 1 as their values.)

SELECT * FROM  `commerce_product` LIMIT 0 , 500

When I put the batch on doing 1 product at a time, it does 18 of the 193 products and then stops and returns the error message.

What I'd like to know is:

  1. How do I check which product is the culprit?

  2. How do I find my indexed items, and how can I find out where it goes wrong? (I'm not using Apache Solr.)

I'm also not quite sure about what is meant by 'the parent data structure is not set'. If anyone could provide any insights, I'd very much appreciate it.

1

It sounds like a field got messed up somewhere. Try running Commerce Repair and seeing if that fixes the problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.