1

I have just created a new content type for my site, and wrote a few rules which act when an instance of that type is created. I went to create a few test instances of my new content type and noticed that it did not appear on that 'Add content' screen (mysite/node/add.) 'No problem' I thought, 'I'll just go to mysite/node/add/new_type.' However, this failed to work too. The page loaded as as the url I submitted, but it appeared to be a duplicate of mysite/node/add. This is a problem because I can not add new content of this type.

I have a few other content type that do not appear on the mysite/node/add, but this was never problematic because I could still create new content of that type by visiting mysite/node/add/some_other_type.

I found that I can create new instances of this content type using Development: Generate Content (and the rules work just fine.) Still, I have yet to figure out why I cant get to the creation page manually. What could be causing this?

Edit ===================================

A newly added content type (just called test with no other changes or fields added) does not appear either (even with all permissions set to 'registered user').

  • Sorry to ask this but have you tried clearing the cache? – Felix Eve Apr 23 '14 at 15:42
  • I just tried, the problem is still there. – Hoytman Apr 23 '14 at 15:44
  • 1
    What are granted permissions? Admin also can't see it? – rreiss Apr 23 '14 at 15:52
  • Do you use Features module? – ya.teck Apr 23 '14 at 15:56
  • I just installed it, but I do not have any active features – Hoytman Apr 23 '14 at 15:57
1

It sounds like there is a problem with your menu system.

This is an (educated) guess but rebuilding your menus may help.

Install the devel module and then click on Rebuild menus:

enter image description here

  • I'm afraid that did not fix the problem – Hoytman Apr 23 '14 at 15:51
  • Hmmph - that would have just been too easy! – Felix Eve Apr 23 '14 at 15:53
  • Which menu is the add content page's submenu based on? There are several other content types missing, so it may be set up wrong – Hoytman Apr 23 '14 at 15:55
  • @Hoytman If it's an option disable then uninstall admin menu, then re-enable it. That does the trick for me sometimes – Clive Apr 23 '14 at 15:58
  • The menu system in this case is referring to URL routing (hook_menu) as opposed to actual visible menus. The node module creates a path for each content type around line 2074. – Felix Eve Apr 23 '14 at 15:59
1

After searching for a few hours, I found this post about a another developer that was experiencing this problem:

http://www.drupalgardens.com/content/new-content-type-not-appearing-add-content

The problem was related to a url that was being used by two different pages. This was causing the navigation menu to break down and only display a limited number of links. Her problem was resolved by renaming one of the urls that her views were creating.

I began to review all of the modules that were creating page links. I was using the 'empty page' module to create pages for my blocks and something was causing this module to generate errors. After removing it, the content creation menu links came back and the node creation pages became accessible.

  • Glad you got to the bottom of it :) – Felix Eve Apr 24 '14 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.