2

I have a site containing Free tagging field using text autocomplete widget option. A view is created with exposed filter for free tagging with autocomplete option. However the results provided via suggestions when entering a tag has html tags, in particular < p > tag.

Is there a way that the tags can be stripped off? Upon selecting the Unformatted dropdown and Unformatted suggestion in the filter option in views option, it displays the numeric id instead of text.

  • Can you not just take the html tags out of the terms in the taxonomy vocabulary? (By just manually editing through the GUI) – Felix Eve Apr 29 '14 at 8:24
  • @FelixEve: This is a text field with an autocomplete widget for existing field data. I had a look at the data saved in database for the text field. The text data did not have any html tags. Its only during views filter suggestions it shows html < p > tags. – Amit Sedai Apr 29 '14 at 9:39
  • I think the field is running through its field formatter and getting the markup. I may have run into this recently. If I did, I'll post what my solution was. – mpdonadio Apr 29 '14 at 14:49
  • @MPD: Great... that would be really helpful. – Amit Sedai Apr 30 '14 at 15:04
0

@MPD: Yes the problem was due to the formatter. The field format was set to Filtered HTML. Once I changed that to Plain Text in Views Exposed Filter settings for the autocomplete filter for the field, it worked. It was a simple change that I did not notice.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.