I'm only using i18n and not Entity Translation.

I've an English version of page set as front page( node/page1).

I've restarted working on my multilingual site after 2 months and previously it was working fine. Earlier I had added French, German, etc translated version of this page.

So if I go to mysite.com/de or mysite.com/fr those translated pages are shown automatically(in short existing translated pages are getting redirected correctly).

But now (after 2 months) when I add translation for untranslated languages like "it" then mysite.com/it does not redirect to the Italian version of the home page.

I've Global Redirect, Translation Redirect enabled. I've also tried clearing all cache several times.

What could be the problem?

  • Looks like a bugreport to me... Have you tried to play with disabling one of your modules and seeing if others work then? Also be advised that if you set 404, you may be deleting redirection headers, as you can have only one status header.
    – Mołot
    Apr 29, 2014 at 11:12
  • not using anything like 404 to this site.
    – AgA
    Apr 29, 2014 at 11:26
  • 1
    I know it is stupid question, but in a case of "usually worked for me" I just have to ask it. Have you thoroughly cleared chaches after adding new language? And considered regenerating aliases, and so on?
    – Mołot
    Apr 29, 2014 at 11:44
  • I tried clearing all cache several times. I had already downloaded and enabled some 18 languages. So Italian was already there. Adding a new Vietnamese or Italian or so page(I mean a new node) will not redirect the site.com/it or site.com/vi to their node versions. I've restarted work in my site after 2 months and it was working fine earlier.
    – AgA
    Apr 29, 2014 at 14:06

1 Answer 1


Your problem might be because of the "language detection" configuration.

So check this configuration via Configuration -> Languages -> detection and selection: the order should be 'URL, Default, User', and not something like 'Default, URL, User'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.