0

i've setup a content type that contains two image fields. One for a main image and the second for 4 smaller images. The trouble i'm having is when you select your image and click upload, there is no response from the browser.

So instead of this:

enter image description here

I get this: enter image description here

Interestingly enough, the images to actually upload, it just doesn't tell the user. Now that wouldn't have been an issue but the second image field requires the user to upload more than one image but because nothing changes, they are unable to.

The only way to add another image is to edit the content and then go and add the second image (and repeat if more images are required). I must have done something wrong?

Just checked the console and I get this JS error:

Uncaught TypeError: Cannot read property 'length' of undefined jquery.js:583
jQuery.extend.each jquery.js:583
Drupal.behaviors.conditionalFields.attach conditional_fields.js?n4i4te:122
(anonymous function) drupal.js?n4i4te:76
jQuery.extend.each jquery.js:605
Drupal.attachBehaviors drupal.js?n4i4te:74
Drupal.ajax.commands.insert ajax.js?v=7.26:542
Drupal.ajax.success ajax.js?v=7.26:400
ajax.options.success ajax.js?v=7.26:164
options.success jquery.form.js?v=2.69:150
cb jquery.form.js?v=2.69:401

Issue may be related to: https://drupal.org/node/1789040

UPDATE: Deactivating the Conditional Fields module fixes the issue but there must be another way?

  • Are any JavaScript errors occurring during upload? I ask because I seem to remember this happening to me and was caused by a js error in tinymce not being compatible with the version of jQuery I was using. – Felix Eve Apr 29 '14 at 15:38
  • Does disabling the conditional fields module solve the problem? – Felix Eve Apr 29 '14 at 15:53
  • Yes it does!...Is there no other way? Really need the conditional fields module :/ – SlightlyClever Apr 29 '14 at 16:01
  • 1
    The only other way is to actually go and fix conditional fields module, if it conflicts with core (and it seems it does). Have you posted bugreport? – Mołot Apr 29 '14 at 20:28
  • The other thing I would suggest is installing the 7.x-3.x-dev version of conditional fields - the bug causing this issue may have been fixed in that release. – Felix Eve Apr 30 '14 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.