I'd like to use the Alfresco Cloud ECM with my Drupal instance. I created an alfresco site. I installed and activated the CMIS module. Here is my configuration script:

$conf['cmis_repositories'] = array(
    'default' => array(
      'label' => 'cmis.alfresco.com',
      'user' => 'my_alfreso_cloud_username@example.de',
      'password' => 'my_alfreso_cloud_password',
      'url' => 'https://cmis.alfresco.com/cmisatom'

I only find these lines to configure the module. Then I added a CMIS field to my content type. When I add a new node then there is an error:

Notice: Undefined index: cmis_field_rootFolderPath in cmis_field_field_widget_form() (line 123 of D:\Inetpub\SK1913\sites\all\modules\cmis\cmis_field\cmis_field.module).

I cannot find any other configuration forms (beside the root path setting).

What am I doing wrong? Does this module work with the alfreso cloud solution? I don't want to install alfreson on my server until I know how to use it, or even if I use it...

  • Which of CMIS modules you use? drupal.org/project/cmis, drupal.org/project/cmis_alfresco, drupal.org/project/cmis_views ?.. – Mołot May 6 '14 at 6:43
  • Please edit to make module name a link to module you are actually using. It will make answering easier for future readers, and will save information you provided if comments are deleted (they are meant to be ephemeral, you know). – Mołot May 6 '14 at 7:09
  • The watchdog gives the following messages: HTTP call to [https://cmis.alfresco.com/cmisatom] returned [0]. Response: The URL seems to be incorrect. When I use the http instead of the https, there is another message: HTTP call to [http://cmis.alfresco.com/cmisatom] returned [403]. Response: Apache Tomcat/6.0.29 - Error report HTTP Status 403 - 04061021301 Failed to authenticatetype Status reportmessage 04061021301 Failed to authenticatedescription Access to the specified resource (04061021301 Failed to authenticate) has been forbidden.Apache Tomcat/6.0.29 – schulle877 May 6 '14 at 7:29
  • EDIT – Mołot May 6 '14 at 7:38

I think there is one more configuration in setting.php for content type mapping with its fields.

In this example i have mapped article content type with cmis type.

$conf['cmis_sync_map'] = array(
 'article' => array(
     'enabled' => TRUE,
     'cmis_sync_cron_enabled' => TRUE,
     'cmis_folderPath' => '/Sites/New/Article',
     'full_sync_next_cron' => TRUE,
     'cmis_sync_nodeapi_enabled' => TRUE,
     'subfolders' => TRUE,
     'cmis_type' => 'alf:article',
     'content_field' => 'body',

$conf['cmis_sync_map']['article']['fields'] = array(
  array('drupal' => 'title', 'cmis' => 'cmis:name', 'drupal to cmis' => TRUE, 'cmis to drupal' => TRUE),
  array('drupal' => 'body', 'cmis' => 'cm:content', 'drupal to cmis' => TRUE, 'cmis to drupal' => TRUE),
  array('drupal' => 'field_object_id', 'cmis' => 'cmis:objectId', 'drupal to cmis' => TRUE, 'cmis to drupal' => TRUE),

I hope it will works for you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.