0

I am using a Zen subtheme with Sass. I am using CodeKit to compile the Sass into CSS. In my workflow, I enjoy using CodeKit's visual system for project settings because then I can use autoprefixer and souremaps etc easily.

Zen comes with Compass support out of the box. In CodeKit, settings for the styles.scss file is disabled, saying "To change options & output paths for Sass files in a Compass project, you must edit the Compass 'config.rb' file directly."

I could find no way to edit the file to make it behave the way I want, so I want to disable Compass completely.

I tried deleting the lines which seemed related with Compass from the sass files, deleting the config.rb but there seems to be a setting somewhere which I cannot find. I checked out the project settigns in CodeKit but could not find a 'switch' to turn Compass off.

In short, how can I take Compass out of Zen's css system and use CodeKit to fine tune the compile settings?

  • 1
    Are you sure you don't have any dependencies on Compass? Compass is in the first place a library of Sass mixins and functions. If you disable Compass, your scss code may fail to compile. – marcvangend May 6 '14 at 13:37
  • @marcvangend - I don't. The theme uses it in some parts but I can live without them. In the comments of the config.rb file it says "If you are not using Compass, you may safely ignore or delete this file." so I think it is possible. – turzifer May 6 '14 at 13:51
0

So Zen uses zen grids for its grid (in some cases) and that has a requirement for compass/css2/images. if you aren't using zen grids, you can disable that dependency.

Another option could be that you can try to delete/rename the config.rb file entirely, as CodeKit may see that and automatically assume you want to use compass to compile your Sass.

A third possibility could be that in the bottom of _init.scss (STARTERKIT/sass/) it pulls in zen, along with alot of other compass extensions. try disabling zen along with the others you already disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.