1

I'm trying to implement something like what's referenced here Image redirection problem, but I closer to the mark with this method http://www.drupalcommerce.org/node/556. The problem I'm having is that this sends me to a 404 page somehow the path is corrupted to this "localhost/drupal//drupal/node/437"

This was done by adding the field Content:Path to my view and excluding it from the display, placed it first in the field order, and then changed the image field by rewriting the result, exporting as link, and using the [path] token as the link itself.

I also tried the same thing with Content: Nid, first field but excluded from display, ditto with the image field but I used the [nid] token. This got me a cleaner path "localhost/drupal/437" but it's still going to a 404 page.

So in the first instance it's writing too much of the path into the link and in the second instance it's not inserting enough of it.

  • localshot/htdocs/drupal/437 ? – Navin Rauniyar May 7 '14 at 3:17
  • typo, but the URL is dropping "node" out of the path, so it should be "siteurl/drupal/node/XXX" I get either 1)"siteurl/drupal//drupal/node/XXX" or 2) "siteurl/drupal/XXX" both resulting in 404's. Htdocs should not be exposed to the user in the path at all. – nizz0k May 7 '14 at 3:22
1

This problem is solved by changing the Content: Path rewrite options to using absolute path.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.