2

When I want to add my user picture, the picture can't upload and when I inspect it the link is broken and get this error:

Warning: array_key_exists() expects parameter 2 to be array, null given in theme_image_formatter() (line 605 of /home/webpenir/public_html/modules/image/image.field.inc).

However, when I add a picture for another user, it works pretty good.

how can I solve this?

EDIT

Only user 1 can't upload but other users can do, which is really strange.

  • 1
    Have you tried to rebuild permissions? – Marcel May 10 '14 at 12:03
  • Thx for your answer , yes but nothing happend – user23811 May 11 '14 at 5:42
1
+25

It is a known issue you can try this patch and Suppose if that patch not workout for you check the other patches here https://drupal.org/node/920840 and if any of that patches not solved your issue then the best option is you have to submit a bug report.

  • thx for your answer , where should i apply this patch !!! in image module ? i know how to apply a patch . – user23811 May 11 '14 at 5:50
  • Soheil you have to learn on how to apply patch, I usually do only on manual method – Bala May 11 '14 at 5:52
  • 1
    To apply patch check this drupal.stackexchange.com/questions/23347/… – Bala May 11 '14 at 5:53
  • 1
    I do only this method fast and easy, but make sure everything is correct drupal.org/node/534548 – Bala May 11 '14 at 5:54
  • Thx for taking your time for me . as i said before i know how to patch , the question is : is this patch for image.module ? – user23811 May 11 '14 at 6:44
1

I think this is your upload location folder permission problem. please ensure that and give your upload location as public:// folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy