2

I installed a pure Drupal on Windows/IIS6 share host, and uploaded several modules in (sites/all/modules). When I want to enable some module together, my administrative pages become white, but front page and other pages work normally.

0

4 Answers 4

11

Take a look at The White Screen of Death (Completely Blank Page) to learn more about the WSOD and how to troubleshoot it.

5
  • is there possible this occur because my host is too weak? on Windows/IIS6 php2.5.6 ? Sep 15, 2011 at 19:58
  • or mySql is weak ... :( Sep 15, 2011 at 20:03
  • It sounds like the PHP memory limit on the server is too low. Did you read that article and try the changes it suggests?
    – Laxman13
    Sep 15, 2011 at 20:17
  • yes, I read!I want to increase memory_limit.in this href="drupal.org/node/31819" on line 8 have written upload my own php.ini file!I don't know what write in file?or I don't know what have php.ini include?:( Sep 15, 2011 at 20:40
  • 1
    If you have chosen to use a php.ini file, put something like this in the file: memory_limit = 64M, then save it and put in your root directory (if on shared hosting). You may need to increase the number depending on how much memory you are using
    – Laxman13
    Sep 15, 2011 at 21:35
3

I guess your display_errors in php.ini is Off, enable it and you'll see your errors instead of white screen

5
  • my control panel is Plesk.How to set display_error on? Sep 14, 2011 at 18:43
  • do u have command line access? if yes then you can find your php.ini at /etc/php.ini
    – Firdous
    Sep 15, 2011 at 8:45
  • or /etc/php5/apache2/php.ini
    – Firdous
    Sep 15, 2011 at 10:34
  • no, I have not access :( Sep 15, 2011 at 17:15
  • follow the link by laxman13, thats a better solution, you can set this in drupal installation as well
    – Firdous
    Sep 15, 2011 at 18:18
1

Check if there is any space in the top of module file before <?php.

0

It's definitely not the best idea to work with Drupal on IIS in first place, however for situation with white screen you've described - I'd say it looks like it's not enough resources (RAM) dedicated to PHP / Drupal.

Solution for this either to increase RAM available for PHP / Drupal or, as option, enable modules via Drush, not admin interface. Thing is that Drush not working that well on Win / IIS platform.

Try checking the normal windows error log if IIS or PHP throw an error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.