1

In a view I show content that contain some fields and an entity reference.

In the Fields part of the view I have a field (Vervaldatum) like this.

enter image description here

The Vervaldatum field is a date field. I would like to have a "Vervaldatum between […] and […]" filter, but when I add a filter and select the Vervaldatum field, I get this.

enter image description here

I was hoping to get "between […] and […]" in the operator field, but no luck. It's like the field is handles as it is a text field, but the in the previous screen it's clear it is a date field.

These are the operators that I can use.

enter image description here

  • I would just add your Vervaldatum field to the filter critera twice, but set different operators for each instance of the exposed field. In other words: Vervaldatum_1 - Operator: Is greater than Vervaldatum_2 - Operator: Is less than I've never tried this method myself, but in theory it should work. – Alex Kirsten May 21 '14 at 11:56
  • I've updated my topic and the operators you suggest are not in the list. – nielsv May 21 '14 at 12:06
  • Oh sorry I didn't realise that, I'm busy taking a closer look to see if I can manage to do something simliar quickly – Alex Kirsten May 21 '14 at 13:24
1

I followed the following steps using a Date field and got the intended result:

Firstly add your date field as a View filter

enter image description here

I left the configure date filter settings as default here

enter image description here

Configured the "greater than" exposed filter

enter image description here

Configured the "less than" exposed filter

enter image description here

Exposed filters appear correctly

enter image description here

Those are the exact steps I followed to get the two exposed date filters. Hope you come right!

  • As you can see I don't have that operators ... He sees it as a text .. – nielsv May 26 '14 at 7:40
  • 1
    Works now, my module Date Views wasn't enabled .. Thanks! – nielsv May 26 '14 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.