I am using Views 7.x-3.8, Drupal 7.28 and Views Data Export 7.x-3.0-beta7.

From a view (page) with multiple fields and exposed filters, I created a homemade search engine with search results within a table. I have created an export view, attached to that view, with exactly the same fields and exposed filters. So users can export filtered search results.

From the search engine, after choosing a value for a field with exposed grouped filter (Any, Yes, No), the export does not consider that choice and keeps the default value for this filter. Same result if I activate the option "Remember last selection" on the export view.

Any idea why?

Thanks in advance.

1 Answer 1


It could be that the export display is not attached to the page display. Try to edit the export display (typically you can not adjust the exposed filters on this page, as visiting the page will simply download all the results for the master view without considering any exposed filters).

Instead of getting your file by visiting the path of the data export, instead attach the data export to the page display where you placed your exposed filters.

You can do this by editing your data export display and adjusting the settings in your "Attach to" settings in the data export settings column (see screenshot below).

enter image description here

Once you click the Attach to link you'll be able to add your data export to any display in that view. Add it to your page. enter image description here

Then, load the page in your browser, adjust your exposed filters until you see the results you want, and then scroll to the bottom of your page. You should see an icon that will enable you to execute the download of whatever file type you specified for your data export. For example, below I've filtered results for a page and set it to download as CSV. enter image description here

By clicking the orange button, I'll download the filtered results on the page.

  • My Export view is already attached to the page where the exposed filters are, actually. My mistake, I said Master view but indeed it is attached to "Page". My problem is the default value always considered by the export instead of the choice made on the dropdown menu for a specific field, within the exposed filters.
    – Toki
    May 24, 2014 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.