1

I'm using a Drupal 7 version website and I'm trying to add a block to a region, when I go in blocks and try to add the block to the region and I do save it reply me that it has been saved but no block is been placed in that region. I'm using omega 4 theme module.
Anyone knows on how I can solve this issue ?

Many thanks to all.

5
  • Have you try clear the cache? If yes try to see if you have tell drupal when to show the block, like is node/1 or in <front> etc. Jun 1 '14 at 20:19
  • yes I've already tried, the problem is that when I try to add the block to a region, it will not be added even if drupal says to me that the changes has been taken place... I'm walkin in the dark :S
    – Gianni
    Jun 1 '14 at 21:07
  • Have you tried to log out and see? What are you have in the block? Have you tell Drupal which page you want the block to show? Jun 1 '14 at 21:14
  • Yes of course, In my block there's the main menu and I'm trying to display it in the navigation region. I don't actually need to say to Drupal in which page display that block because it needs to be displayed in all the pages.
    – Gianni
    Jun 1 '14 at 22:18
  • Do you try change your theme to one of default themes and make your change and see result? it help you to know where is your problem, in your theme or another reason
    – Yuseferi
    Jun 2 '14 at 5:08
1

I had a similar issue. But I had Bean and Bean-all module installed, so only in the blocks ticked in admin/config/system/bean-all the move/edit actions were "real" or commited, although success message was showed in the non-ticked ones.

1
  • 1
    I dont get why you'd vote -1... It's my answer. Found out the answer the hard way and get voted down... it's ironic... Nov 18 '14 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.