1

I'm new to Drupal so I may have done something horribly wrong.

Using Drupal 7.

I tried to create a custom home page by using the Page builder. I created a page template and assigned it to be used as the home page. Then decided against and deleted the template.

Now I get a 404 response when I go to my home page. The rest of the site works and shows all the pages. I tried clearing the cache but no luck.

Andy help or ideas would be greatly appreciated. Thank you

3
  • did you simply delete the template file? chances are the settings are still looking for that file. Depending on how you set it up will dictate how to change it back to default.
    – Geoff
    Jun 4, 2014 at 0:10
  • Restore from backup? Or git revert? Or any other way you use to prevent accidents with your files? For future, disable first delete later. But if it's your development environment, restoring previous state should be pretty easy, and data loss insignificant, wouldn't it?
    – Mołot
    Jun 4, 2014 at 6:46
  • I used the settings in the admin under administration>>structure>>pages. Created a new page and apparently had set the variant to be a 404 message. So how can I turn this off? There are only HTTP responses to select from in the variants so it doesn't look like I can do anything else with the "pages" in this interface. I just want to turn this off, how do I do that?
    – dkmojo
    Jun 4, 2014 at 12:51

1 Answer 1

0

I figured out the answer. I needed to install the Panels module so that I could use it as a variant. And that allowed me to set my home page template the way I needed it to be. Sorry for any confusion I may have caused with my question. And thanks for the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.