0

I am getting url example.com/?= and I want this example.com
I have tried .htaccess method but nothing happened.
I have also gone through may link like clean urls but nothing happened My clean URLs test fail.

Please help.

3 Answers 3

0

It will sound silly but it can help you.
Go to /admin/config/search/clean-urls
you will get example.com/?=admin/config/search/clean-urls in your address bar
remove ?= from address bar so that your url become example.com/admin/config/search/clean-urls
press enter
Now you will get a check box
tick that box and save configration.

May this Helps you.

2
  • 1
    Really it was so simple. I have been stuck in it for hours, tried every possible aspects on net. Thank you
    – Amrita
    Jun 5, 2014 at 13:27
  • 1
    Not sure why there was a downvote. Even if it has been answered earlier this is a perfectly valid answer. Adding my +1.
    – AjitS
    Jun 8, 2014 at 12:33
0

First thing first, try enabling "rewrite" module for apache,

sudo a2enmod rewrite

After that You need to replace the occurrence of AllowOverride none to AllowOverride all in your site-available file

sudo vim /etc/apache2/sites-available/default

And finally you need to enable clean-url form your drupal site.

Home » Administration » Configuration » Search and metadata

OR navigate to

http://example.com/admin/config/search/clean-urls

0

Enable mod_rewrite apache from httpd.conf

  1. open httpd.conf
  2. find mod_rewrite
  3. just remove # to enable
  4. once it enable then you can run Clean URL
  5. this will show check box tick on it and save it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.