0

When I am logged in as the root admin, I am able to create Rule Components (rule and rule sets) and have them appear in the View Bulk Operations (VBO) settings menu as an option for a VBO view table column. As the root admin, I can also navigate to the view's page and successfully perform the Rule Component on table entries using the VBO interface.

However, when I log in as another user (seemingly regardless of role or permission) The Rule Component options which were enabled for the VBO column are no longer available. It appears that some sort of permission is blocking them. It is not obvious which permission (or if it is a permission) is blocking the Rule Component Options so they don't appear in the VBO list.

Does anyone have experience with this problem and knows a way to get Rule Components to appear in the VBO drop down in a view for all users?

marked as duplicate by kiamlaluno Jun 12 '14 at 21:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

If you are adding operations using Rules Component then you have to set the permission.

Edit your rule component and under the settings there will be Configure access for using this component with a permission, set your permission here.

  • Yeah, that was the root cause of this problem (too) – Hoytman Jun 12 '14 at 15:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.